Slow printing when using Windows 2008 Server as Print Server

Consider the following scenario:
  • You have a Windows Server 2008-based print server.
  • This print server has many Windows Vista-based printer clients.
In this scenario, the memory usage of the Print Spooler service increases significantly over time. For example, this issue occurs when several thousand printer clients send their print jobs to the print server. Eventually, the print server becomes unresponsive, and you must restart the server to recover from this problem. Depending on the printing load, this problem may occur after the system has been running for one day or for several weeks.

Additionally, when a user tries to print documents from a Windows Vista-based computer, the print job randomly fails, and the user receives the following error message:
Windows cannot connect to the printer. The server print spooler service is not running. Please restart the spooler on the server or restart the server machine

CAUSE
This problem occurs because of a memory leak in the Print Spooler service. The P...

This problem occurs because of a memory leak in the Print Spooler service. The Print Spooler service maintains an unbounded client notification queue. Additionally, the Print Spooler service caches a printer DEVMODE structure for every client handle that is opened. In combination, these two functionalities consume lots of memory when many printer clients access this print server.

Additionally, Windows Vista-based printer clients use asynchronous remote procedure calls (RPCs) to retrieve printer change notifications. Therefore, many asynchronous RPCs are scheduled when many printer clients use the print server. After the total number of dispatched RPCs reaches a limit of 6,000, the client user receives the error message that is mentioned in the "Symptoms" section.

RESOLUTION
Hotfix informationA supported hotfix is available from Microsoft. However, this...

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)  
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, x86-based versions
 
File nameFile versionFile sizeDateTimePlatform
Localspl.dll 6.0.6001.22200 634,368 11-Jun-2008 05:23 x86
Spoolss.dll 6.0.6001.22200 163,840 11-Jun-2008 05:23 x86
Spoolsv.exe 6.0.6001.22200 126,976 11-Jun-2008 03:41 x86
Windows Server 2008, Itanium-based versions
 
File nameFile versionFile sizeDateTimePlatformService branch
Localspl.dll 6.0.6001.22200 1,617,920 11-Jun-2008 05:36 IA-64 Not available
Spoolss.dll 6.0.6001.22200 446,464 11-Jun-2008 05:39 IA-64 Not available
Spoolsv.exe 6.0.6001.22200 437,248 11-Jun-2008 04:19 IA-64 Not available
Localspl.dll 6.0.6001.22200 634,368 11-Jun-2008 05:23 x86 SysWOW64
Spoolss.dll 6.0.6001.22200 163,840 11-Jun-2008 05:23 x86 SysWOW64
Windows Server 2008, x64-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Localspl.dll 6.0.6001.22200 788,480 11-Jun-2008 05:50 x64 Not available
Spoolss.dll 6.0.6001.22200 241,664 11-Jun-2008 05:50 x64 Not available
Spoolsv.exe 6.0.6001.22200 268,800 11-Jun-2008 04:26 x64 Not available
Localspl.dll 6.0.6001.22200 634,368 11-Jun-2008 05:23 x86 SysWOW64
Spoolss.dll 6.0.6001.22200 163,840 11-Jun-2008 05:23 x86 SysWOW64

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that ar...

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION
For more information about software update terminology, click the following arti...

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

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